Blast Management

System Requirements

The minimum requirements for running BLASTPLAN-PRO™ are:

A PC with a 2.4Ghz Pentium 4 Processor or greater and either Microsoft Windows® XP Service Pack 2 or above with at least 1GB of memory or Windows Vista®/ Windows 7® with at least 2 GB of memory.

Microsoft .NET 2.0 or greater must be installed on the operating system. This is supplied as standard in Windows® XP Service Pack 3 and above, Windows® Vista and Windows® 7 but can be downloaded via Microsoft Windows® Update if your are running earlier versions of Windows® XP.

BLASTPLAN-PRO™ will work with all Video Cards but good quality video cards are recommended for improved performance.

It is recommended that the system you are running has the latest Windows® Updates installed.